summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Stürmer <michael.stuermer@schaeffler.com>2017-01-09 15:34:13 (GMT)
committerMichael Stürmer <michael.stuermer@schaeffler.com>2017-01-13 08:28:13 (GMT)
commita7dd8e669289e7b78ebc05b5d337052f32582038 (patch)
tree5142590a9f2f520e4dc0f9e70524d633c8f3a023 /Tests/CMakeLists.txt
parent6fda6005b306cc4a1e9e9e66d9cd4525fc623f73 (diff)
downloadCMake-a7dd8e669289e7b78ebc05b5d337052f32582038.zip
CMake-a7dd8e669289e7b78ebc05b5d337052f32582038.tar.gz
CMake-a7dd8e669289e7b78ebc05b5d337052f32582038.tar.bz2
VS: added support for C# (for Visual Studio 2010, 2012, 2013, 2015)
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 73eef9a..4945b31 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -325,6 +325,9 @@ if(BUILD_TESTING)
endif()
endif()
+ if(${CMAKE_GENERATOR} MATCHES "Visual Studio ([^789]|[789][0-9])")
+ ADD_TEST_MACRO(CSharpOnly CSharpOnly)
+ endif()
ADD_TEST_MACRO(COnly COnly)
ADD_TEST_MACRO(CxxOnly CxxOnly)