summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-06-14 13:00:39 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2013-06-14 13:00:39 (GMT)
commited2f59e6149ab763c20653365fb881a9b9e315fd (patch)
treed41c7de688bf44e23ea7a8d9128316a5a23d837a /Tests/CMakeLists.txt
parentbbaae3e42150db41c3386c80a631e1134ac085d5 (diff)
parent6a6cda5b4a0fe561cc5f5b7d6ec12775d17a4457 (diff)
downloadCMake-ed2f59e6149ab763c20653365fb881a9b9e315fd.zip
CMake-ed2f59e6149ab763c20653365fb881a9b9e315fd.tar.gz
CMake-ed2f59e6149ab763c20653365fb881a9b9e315fd.tar.bz2
Merge topic 'suppress-unused-cli-with-value-in-cache'
6a6cda5 Don't run the WarnUnusedCliUnused test on Windows.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index b742dad..621c5f4 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1640,7 +1640,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
FAIL_REGULAR_EXPRESSION "CMake Warning .*VariableUnusedViaUnset.CMakeLists.txt:5 \\(set\\):")
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/WarnUnusedUnusedViaUnset")
- if("${CMAKE_TEST_GENERATOR}" MATCHES "Makefile")
+ if("${CMAKE_TEST_GENERATOR}" MATCHES "Makefile" AND NOT WIN32)
# Ninja does not support ADDITIONAL_MAKE_CLEAN_FILES and therefore fails
# this test. (See #13371)
# Apparently Visual Studio does not support it either. As the MakeClean