summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Woehlke <matthew.woehlke@kitware.com>2016-05-31 14:51:25 (GMT)
committerBrad King <brad.king@kitware.com>2016-06-07 12:50:36 (GMT)
commit95d84369b802473e22bcb662a86175621bba54c6 (patch)
tree2ed6f3f24884298ee77fdae27d32f57d6dfc1699 /Tests/CMakeLists.txt
parent5341c0d84af50c2ac5e4041885ab96f8d157ddfe (diff)
downloadCMake-95d84369b802473e22bcb662a86175621bba54c6.zip
CMake-95d84369b802473e22bcb662a86175621bba54c6.tar.gz
CMake-95d84369b802473e22bcb662a86175621bba54c6.tar.bz2
Tests: Add test for exported JARs
Add a unit test to test the new functions to export JAR targets. The test builds three sub-projects: two that generate and export a JAR (one does a build-directory-only export, one an install-only export), and a third that consumes the first two as imported targets.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 9442ea7..24b42ee 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -3104,6 +3104,10 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
find_package(Java COMPONENTS Development QUIET)
if(Java_JAVA_EXECUTABLE AND Java_JAVAC_EXECUTABLE AND Java_JAR_EXECUTABLE AND NOT MINGW
AND NOT "${CMAKE_GENERATOR}" MATCHES "Xcode")
+
+ set(JavaExportImport_BUILD_OPTIONS -DCMake_TEST_NESTED_MAKE_PROGRAM:FILEPATH=${CMake_TEST_EXPLICIT_MAKE_PROGRAM})
+ ADD_TEST_MACRO(JavaExportImport JavaExportImport)
+
get_filename_component(JNIPATH ${JAVA_COMPILE} PATH)
find_file(JNI_H jni.h
"${JNIPATH}/../include"