summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2012-08-20 19:41:06 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-08-20 19:41:06 (GMT)
commit407ccb495752de28e788842275fd798ef9fcc02a (patch)
treee3f36450d373b02cb6230061461da9b48a973fad /Tests/CMakeLists.txt
parent135914f01e4841acdcd0ef840f7d67e56b30bbe2 (diff)
parent11f23fee523347a52eb36d439f89b5bd6e99fa6b (diff)
downloadCMake-407ccb495752de28e788842275fd798ef9fcc02a.zip
CMake-407ccb495752de28e788842275fd798ef9fcc02a.tar.gz
CMake-407ccb495752de28e788842275fd798ef9fcc02a.tar.bz2
Merge topic 'RemoveNonworkingKDE4Test'
11f23fe remove non-working KDE4 test
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt42
1 files changed, 0 insertions, 42 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 230df63..35a8d41 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -70,11 +70,6 @@ if(BUILD_TESTING)
"Should the tests that run a full sub ctest process be run?"
OFF)
mark_as_advanced(CTEST_TEST_CTEST)
-
- option(TEST_KDE4_STABLE_BRANCH
- "Should the KDE4 stable branch test be run?"
- OFF)
- mark_as_advanced(TEST_KDE4_STABLE_BRANCH)
endif ()
# Should tests that use CVS be run?
@@ -2112,43 +2107,6 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
endif ()
endif ()
- if (CMAKE_RUN_LONG_TESTS AND TEST_KDE4_STABLE_BRANCH)
- if(UNIX)
- if(NOT QT4_FOUND)
- find_package(Qt4)
- endif()
-
- set(TRY_BUILD_KDE4 TRUE)
- if(QT4_FOUND)
- # check whether it's Qt 4.5 in a cmake 2.4. compatible way:
- if(NOT EXISTS "${QT_QTNETWORK_INCLUDE_DIR}/QAbstractNetworkCache")
- set(TRY_BUILD_KDE4 FALSE)
- endif()
- else()
- set(TRY_BUILD_KDE4 FALSE)
- endif()
-
- find_package(Perl)
- if(NOT PERL_FOUND)
- set(TRY_BUILD_KDE4 FALSE)
- endif()
-
- find_package(ZLIB)
- if(NOT ZLIB_FOUND)
- set(TRY_BUILD_KDE4 FALSE)
- endif()
-
- if(TRY_BUILD_KDE4)
- file(MAKE_DIRECTORY ${CMake_BINARY_DIR}/Tests/KDE4StableBranchTest)
- set(TEST_KDE4_BASE_DIR ${CMake_BINARY_DIR}/Tests/KDE4StableBranchTest)
- configure_file(${CMake_SOURCE_DIR}/Tests/KDE4StableBranchTest/test_kde4.sh.in ${CMake_BINARY_DIR}/Tests/KDE4StableBranchTest/test_kde4.sh @ONLY)
- execute_process(COMMAND chmod 755 ${CMake_BINARY_DIR}/Tests/KDE4StableBranchTest/test_kde4.sh )
- add_test(KDE4StableBranchTest ${CMake_BINARY_DIR}/Tests/KDE4StableBranchTest/test_kde4.sh)
- endif()
-
- endif()
- endif ()
-
if("${CMAKE_TEST_GENERATOR}" MATCHES Xcode)
set(CMAKE_SKIP_BOOTSTRAP_TEST 1)
endif()