summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-04-05 18:28:38 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2011-04-05 18:28:38 (GMT)
commitfff3a742b256afdbc6515f451a7283c1b34f5af4 (patch)
tree13fbac0f360c3f7b8add4306e9132f60e1556ec9 /Tests/CMakeLists.txt
parentc3c19c7cb76a2522bb01421ce1f790b1f7638ebe (diff)
parent3e32db79216f145c4f0560387b83c3a9b7da2964 (diff)
downloadCMake-fff3a742b256afdbc6515f451a7283c1b34f5af4.zip
CMake-fff3a742b256afdbc6515f451a7283c1b34f5af4.tar.gz
CMake-fff3a742b256afdbc6515f451a7283c1b34f5af4.tar.bz2
Merge topic 'upload-built-files'
3e32db7 cmCTestUploadCommand::CheckArgumentKeyword should return false if not FILES 6b6f309 Add the FILES keyword to ctest_upload command 28cdd0a Don't tar/gz ctest_upload() files fbe4356 Change 'Files' tag to 'Upload' in Upload.xml 350546d Implement ctest_upload command
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 6265f81..ea6a416 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1442,6 +1442,16 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
PASS_REGULAR_EXPRESSION "Could not find executable"
FAIL_REGULAR_EXPRESSION "SegFault")
+ CONFIGURE_FILE(
+ "${CMake_SOURCE_DIR}/Tests/CTestTestUpload/test.cmake.in"
+ "${CMake_BINARY_DIR}/Tests/CTestTestUpload/test.cmake"
+ @ONLY ESCAPE_QUOTES)
+ ADD_TEST(CTestTestUpload ${CMAKE_CTEST_COMMAND}
+ -S "${CMake_BINARY_DIR}/Tests/CTestTestUpload/test.cmake" -V
+ --output-log "${CMake_BINARY_DIR}/Tests/CTestTestUpload/testOut.log"
+ )
+ SET_TESTS_PROPERTIES(CTestTestUpload PROPERTIES
+ PASS_REGULAR_EXPRESSION "Upload\\.xml")
# Use macro, not function so that build can still be driven by CMake 2.4.
# After 2.6 is required, this could be a function without the extra 'set'