summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSilvio <silvio@traversaro.it>2022-04-03 15:25:12 (GMT)
committerBrad King <brad.king@kitware.com>2022-04-05 12:27:09 (GMT)
commit178cf34bdc5234e07442d0007c39e2d184b4261f (patch)
tree19c93e758675df831ef5abafa9099da368258f7d /Tests/CMakeLists.txt
parentfff8f3bee92d9f139c48cdc194ca826447fc402a (diff)
downloadCMake-178cf34bdc5234e07442d0007c39e2d184b4261f.zip
CMake-178cf34bdc5234e07442d0007c39e2d184b4261f.tar.gz
CMake-178cf34bdc5234e07442d0007c39e2d184b4261f.tar.bz2
FindMatlab: Add NO_IMPLICIT_LINK_TO_MATLAB_LIBRARIES option to matlab_add_mex
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 3ce9b48..d663a14 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1558,6 +1558,9 @@ if(BUILD_TESTING)
set(FindMatlab.targets_checks_BUILD_OPTIONS ${FindMatlab_additional_test_options})
ADD_TEST_MACRO(FindMatlab.targets_checks ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>)
set_property(TEST FindMatlab.targets_checks APPEND PROPERTY LABELS "Matlab")
+ set(FindMatlab.no_implicit_link_checks_BUILD_OPTIONS ${FindMatlab_additional_test_options})
+ ADD_TEST_MACRO(FindMatlab.no_implicit_link_checks ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>)
+ set_property(TEST FindMatlab.no_implicit_link_checks APPEND PROPERTY LABELS "Matlab")
endif()
set(ExternalProject_BUILD_OPTIONS "")