summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2010-05-06 18:37:55 (GMT)
committerBrad King <brad.king@kitware.com>2010-05-06 18:37:55 (GMT)
commit4d653fb4eebd4819f3283d27844daf6f12ca24c6 (patch)
treea3c043ba159fe718d694cca0356e3809b3de3a79 /Tests/CMakeLists.txt
parenta443308c37c41edf75dabaf87feee33bb57212b6 (diff)
downloadCMake-4d653fb4eebd4819f3283d27844daf6f12ca24c6.zip
CMake-4d653fb4eebd4819f3283d27844daf6f12ca24c6.tar.gz
CMake-4d653fb4eebd4819f3283d27844daf6f12ca24c6.tar.bz2
Fix 'Architecture' test for more Mac linkers
Some Mac linkers produce the message "file was built for unsupported file format which is not the architecture being linked" for this test. Update the test output regex to match it.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 07f5e7d..6159265 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -159,7 +159,7 @@ IF(BUILD_TESTING)
IF(CTEST_TEST_OSX_ARCH)
ADD_TEST_MACRO(Architecture Architecture)
SET_TESTS_PROPERTIES(Architecture PROPERTIES
- PASS_REGULAR_EXPRESSION "(file is not of required architecture|does not match cputype)")
+ PASS_REGULAR_EXPRESSION "(file is not of required architecture|does not match cputype|not the architecture being linked)")
ENDIF(CTEST_TEST_OSX_ARCH)
LIST(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})