summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-02-04 17:30:10 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2015-02-04 17:30:10 (GMT)
commit8f820043684fa8a11289061297828bccce7ba080 (patch)
tree9d63bfb8a223a6bbc8796bceaa0f614619f0d234 /Tests/CMakeLists.txt
parent5f3778571770ccbceca22aa18ad06f1779a3ca5a (diff)
parent809a5a5e2391484966614f11100de956619adda6 (diff)
downloadCMake-8f820043684fa8a11289061297828bccce7ba080.zip
CMake-8f820043684fa8a11289061297828bccce7ba080.tar.gz
CMake-8f820043684fa8a11289061297828bccce7ba080.tar.bz2
Merge topic 'CTestCoverageCollectGCOV-refinements'
809a5a5e Help: Add notes for topic 'CTestCoverageCollectGCOV-refinements' 03c0812c CTestCoverageCollectGCOV: Fix handling of international characters 8caa4e72 CTestCoverageCollectGCOV: Add test case 5c828cc8 CTestCoverageCollectGCOV: Allow custom flags to gcov 30cb628e CTestCoverageCollectGCOV: Fix handling of large file counts
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 035f161..7e7aa2e 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2269,6 +2269,18 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
PASS_REGULAR_EXPRESSION "Upload\\.xml")
configure_file(
+ "${CMake_SOURCE_DIR}/Tests/CTestCoverageCollectGCOV/test.cmake.in"
+ "${CMake_BINARY_DIR}/Tests/CTestCoverageCollectGCOV/test.cmake"
+ @ONLY ESCAPE_QUOTES)
+ add_test(CTestCoverageCollectGCOV ${CMAKE_CTEST_COMMAND}
+ -S "${CMake_BINARY_DIR}/Tests/CTestCoverageCollectGCOV/test.cmake" -VV
+ --output-log "${CMake_BINARY_DIR}/Tests/CTestCoverageCollectGCOV/testOut.log"
+ )
+ set_tests_properties(CTestCoverageCollectGCOV PROPERTIES
+ PASS_REGULAR_EXPRESSION
+ "PASSED with correct output.*Testing/CoverageInfo/echoargs.gcov")
+
+ configure_file(
"${CMake_SOURCE_DIR}/Tests/CTestTestEmptyBinaryDirectory/test.cmake.in"
"${CMake_BINARY_DIR}/Tests/CTestTestEmptyBinaryDirectory/test.cmake"
@ONLY ESCAPE_QUOTES)