summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-08-29 18:39:05 (GMT)
committerBrad King <brad.king@kitware.com>2019-08-29 18:39:05 (GMT)
commit2c71208a78f47f59972a3a39b1f038d293abd83b (patch)
treeeeab82f7a88a98a8fab7bd77661d7ce1073b003a /Tests/CMakeLists.txt
parent3ec986ce8e8df269eb6b6b9f37e12b02194168fd (diff)
downloadCMake-2c71208a78f47f59972a3a39b1f038d293abd83b.zip
CMake-2c71208a78f47f59972a3a39b1f038d293abd83b.tar.gz
CMake-2c71208a78f47f59972a3a39b1f038d293abd83b.tar.bz2
Tests: Fix nightly binary tests to fail on error
We generate a small shell script to drive the steps. Previously a failure in the `release_cmake.cmake` script was not diagnosed and hidden from the script exit code by the following upload step. Tell the shell to terminate with failure on the first command that fails.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 02e28d4..cbd7d56 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -764,7 +764,8 @@ if(BUILD_TESTING)
set(_TEST_DIR "${CMake_BINARY_DIR}/Tests/${name}")
file(MAKE_DIRECTORY "${_TEST_DIR}")
file(WRITE "${_TEST_DIR}/nightly-cmake.sh"
- "cd ${_TEST_DIR}
+ "set -e
+cd ${_TEST_DIR}
${CMake_BINARY_DIR}/bin/cmake -DCMAKE_CREATE_VERSION=nightly -P ${CMake_SOURCE_DIR}/Utilities/Release/${script}
${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGHTLY_RELEASES}'
")