summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-11-30 15:57:43 (GMT)
committerKitware Robot <kwrobot@kitware.com>2017-11-30 15:57:52 (GMT)
commit92b212e87542552a8dd095608098609a3ebe1d6d (patch)
tree16787e74a21534590493b7237271aeba2443b27d /Tests/CMakeLists.txt
parentc2ea729c87cee2fb19d34090ef00e42d12fb59f2 (diff)
parent1e9b7d3ceb882d3feb59324b6e55d40cc795576b (diff)
downloadCMake-92b212e87542552a8dd095608098609a3ebe1d6d.zip
CMake-92b212e87542552a8dd095608098609a3ebe1d6d.tar.gz
CMake-92b212e87542552a8dd095608098609a3ebe1d6d.tar.bz2
Merge topic 'libuv-raii'
1e9b7d3c server: Switched to a auto model for handles f43b9219 tests: Added tests to verify UV RAII semantics/constructs a3abb85c Add RAII handles for libuv handle types 90f8db26 tests: unconditionally enabled server tests b56b51fc utility: Disabled copy ctors in thread classes Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !1453
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index a61864f..9507880 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -149,9 +149,7 @@ if(BUILD_TESTING)
if(NOT CMake_TEST_EXTERNAL_CMAKE)
add_subdirectory(CMakeLib)
- if(CMake_TEST_SERVER_MODE)
- add_subdirectory(CMakeServerLib)
- endif()
+ add_subdirectory(CMakeServerLib)
endif()
add_subdirectory(CMakeOnly)
add_subdirectory(RunCMake)