summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2008-10-29 16:27:19 (GMT)
committerDavid Cole <david.cole@kitware.com>2008-10-29 16:27:19 (GMT)
commitb0536e29eaf2edbf798cd98884eb3a31ebf4f781 (patch)
tree184f3822ad64282e966085c11292aa93b6a633af /Tests/CMakeLists.txt
parent351ef7c187e0d29caef23db7add58bf214b42951 (diff)
downloadCMake-b0536e29eaf2edbf798cd98884eb3a31ebf4f781.zip
CMake-b0536e29eaf2edbf798cd98884eb3a31ebf4f781.tar.gz
CMake-b0536e29eaf2edbf798cd98884eb3a31ebf4f781.tar.bz2
ENH: Use settings for CPackComponents test to make it fail if the recent fix of cmCPackGenerator.cxx revision 1.16 ever encounters another regression.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 74a59a2..b0310ed 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -391,6 +391,9 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=CVS -P ${CMake_SOURCE_DIR}/Utilities/Rel
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
--build-two-config
--build-target package
+ --build-options
+ -DCPACK_BINARY_DEB:BOOL=${CPACK_BINARY_DEB}
+ -DCPACK_BINARY_RPM:BOOL=${CPACK_BINARY_RPM}
--test-command ${CMAKE_CMAKE_COMMAND}
"-DCPackComponents_BINARY_DIR:PATH=${CMake_BINARY_DIR}/Tests/CPackComponents"
-P "${CMake_SOURCE_DIR}/Tests/CPackComponents/VerifyResult.cmake")