summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2022-10-21 13:25:08 (GMT)
committerBrad King <brad.king@kitware.com>2022-11-09 15:22:46 (GMT)
commitce4babb5669b9fcd8ff3d34c109eeca598144ce4 (patch)
treeb82900c3ee0fc960130ffdaa43c2fcbb86ac498f /Tests/CMakeLists.txt
parent16cb04dbe9448554c97f407af38c1df1a2f3f953 (diff)
downloadCMake-ce4babb5669b9fcd8ff3d34c109eeca598144ce4.zip
CMake-ce4babb5669b9fcd8ff3d34c109eeca598144ce4.tar.gz
CMake-ce4babb5669b9fcd8ff3d34c109eeca598144ce4.tar.bz2
Tests: Fix ARM64 test conditions for non-VS generators
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 112455b..030f4f6 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2164,7 +2164,7 @@ if(BUILD_TESTING)
if(MSVC AND NOT MSVC_VERSION LESS 1310
AND (NOT CMAKE_GENERATOR MATCHES "Visual Studio 9 "
OR CMAKE_SIZEOF_VOID_P EQUAL 4)
- AND (NOT CMAKE_VS_PLATFORM_NAME STREQUAL "ARM64")
+ AND (NOT CMAKE_C_COMPILER_ARCHITECTURE_ID STREQUAL "ARM64")
)
ADD_TEST_MACRO(VSMASM VSMASM)
endif()