summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Neundorf <neundorf@kde.org>2018-01-23 22:03:56 (GMT)
committerBrad King <brad.king@kitware.com>2018-01-24 13:30:02 (GMT)
commit9198e6a27b02a39ae5b7a96839e54da6588c3a3f (patch)
tree9bdf91162477bcd4d1bbd9cf1c41a488709faa25 /Tests/CMakeLists.txt
parent1345bdf1b6520a2f0c9891ad3c6fee00a6a5f18d (diff)
downloadCMake-9198e6a27b02a39ae5b7a96839e54da6588c3a3f.zip
CMake-9198e6a27b02a39ae5b7a96839e54da6588c3a3f.tar.gz
CMake-9198e6a27b02a39ae5b7a96839e54da6588c3a3f.tar.bz2
Generators: remove KDevelop3 generator
The last KDevelop3 release was many years ago, in 2008 I think. I haven't seen or read about anybody using KDevelop 3 since a long time, so I think it can safely be removed from CMake. KDevelop 4 (first released in 2010) has its own proper CMake support now, independent from this generator. Alex
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index fb7313f..8b38a70 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -624,7 +624,6 @@ if(BUILD_TESTING)
"CodeLite"
"Eclipse CDT4"
"Kate"
- "KDevelop3"
"Sublime Text 2")
foreach(extraGenerator ${extraGenerators})
@@ -3224,7 +3223,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
endif()
# add some cross compiler tests, for now only with makefile based generators
- if(CMAKE_GENERATOR MATCHES "Makefiles" OR CMAKE_GENERATOR MATCHES "KDevelop")
+ if(CMAKE_GENERATOR MATCHES "Makefiles")
# if sdcc is found, build the SimpleCOnly project with sdcc
find_program(SDCC_EXECUTABLE sdcc)