summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-06-19 15:12:50 (GMT)
committerBrad King <brad.king@kitware.com>2018-06-19 15:14:43 (GMT)
commitca6920689300249f67c4914cef521963c72a0d3f (patch)
tree5e7f09301cf86bc236d7dad2d08c1c5dafb1d644 /Tests/CMakeLists.txt
parent71fa78ff7af90c8384f1697ea1d0c2df0e0877c9 (diff)
downloadCMake-ca6920689300249f67c4914cef521963c72a0d3f.zip
CMake-ca6920689300249f67c4914cef521963c72a0d3f.tar.gz
CMake-ca6920689300249f67c4914cef521963c72a0d3f.tar.bz2
Tests: Do not use i386 architecture with Xcode 10 and above
Xcode 10 dropped support for i386 builds.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 886e392..b8b724e 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -252,6 +252,10 @@ if(BUILD_TESTING)
set(CMake_TEST_XCODE_VERSION "${CMAKE_MATCH_1}")
endif()
endif()
+ if(NOT CMake_TEST_XCODE_VERSION VERSION_LESS 10)
+ # Since Xcode 10 we do not have two supported architectures for the host.
+ set(CTEST_TEST_OSX_ARCH 0)
+ endif()
if(CMAKE_OSX_SYSROOT)
execute_process(
COMMAND xcodebuild -sdk ${CMAKE_OSX_SYSROOT} -version ProductName