summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-01-22 14:15:16 (GMT)
committerBrad King <brad.king@kitware.com>2008-01-22 14:15:16 (GMT)
commitd2d18fb56584b1446981986a3ab0440cacd42e41 (patch)
treedc4737f2c12845b85a5b668dc6b88fc25703f4cb /Tests/CMakeLists.txt
parent96fd5909d9dd1ffe740230ce652d574cd01c62d5 (diff)
downloadCMake-d2d18fb56584b1446981986a3ab0440cacd42e41.zip
CMake-d2d18fb56584b1446981986a3ab0440cacd42e41.tar.gz
CMake-d2d18fb56584b1446981986a3ab0440cacd42e41.tar.bz2
ENH: Added RuntimePath test to make sure rpath gets correct order.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index f0afcae..3c5d051 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -498,6 +498,9 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=CVS -P ${CMake_SOURCE_DIR}/Utilities/Rel
--build-two-config
--test-command bin/example)
+ IF(CMAKE_SHARED_LIBRARY_RUNTIME_C_FLAG)
+ ADD_TEST_MACRO(RuntimePath RuntimePath)
+ ENDIF(CMAKE_SHARED_LIBRARY_RUNTIME_C_FLAG)
ENDIF("${CMAKE_SYSTEM_NAME}" MATCHES syllable)