summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-09-12 14:38:32 (GMT)
committerBrad King <brad.king@kitware.com>2014-09-15 14:26:59 (GMT)
commitd506fee81ca8fca7fe0c91da4bd4a3551d210b06 (patch)
tree3af2748680dbfd8b4cc08f27ab22357c3ec3ca61 /Tests/CMakeLists.txt
parent11c9ddd6949eb7725de1f6b459508b23a81f25c1 (diff)
downloadCMake-d506fee81ca8fca7fe0c91da4bd4a3551d210b06.zip
CMake-d506fee81ca8fca7fe0c91da4bd4a3551d210b06.tar.gz
CMake-d506fee81ca8fca7fe0c91da4bd4a3551d210b06.tar.bz2
Tests: Use -A option to pass generator platform selection
This is less verbose than defining CMAKE_GENERATOR_PLATFORM.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 0b4aef7..98e2e76 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1988,7 +1988,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
# A test for ctest_build() with targets in subdirectories
set(ctest_configure_options)
if(CMAKE_GENERATOR_PLATFORM)
- list(APPEND ctest_configure_options -DCMAKE_GENERATOR_PLATFORM=${CMAKE_GENERATOR_PLATFORM})
+ list(APPEND ctest_configure_options -A ${CMAKE_GENERATOR_PLATFORM})
endif()
if(CMAKE_GENERATOR_TOOLSET)
list(APPEND ctest_configure_options -T ${CMAKE_GENERATOR_TOOLSET})