summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-10-19 20:16:58 (GMT)
committerBrad King <brad.king@kitware.com>2008-10-19 20:16:58 (GMT)
commite12f299f9d04f166640532345c1dec89610e575c (patch)
tree41944a3fd700dc05c2a0faf174107642adad1869 /Tests/CMakeLists.txt
parent3584a4eceb8032c36a896952a87143fcf38d4ffb (diff)
downloadCMake-e12f299f9d04f166640532345c1dec89610e575c.zip
CMake-e12f299f9d04f166640532345c1dec89610e575c.tar.gz
CMake-e12f299f9d04f166640532345c1dec89610e575c.tar.bz2
ENH: Enable cvs update test with CMake before 2.6
When CMake is built by CMake 2.4 or lower the FindCVS module is not available. In that case we activiate CTest.UpdateCVS by searching for the cvs command directly.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index deffd9f..74a59a2 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -857,7 +857,12 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=CVS -P ${CMake_SOURCE_DIR}/Utilities/Rel
MARK_AS_ADVANCED(CTEST_TEST_UPDATE_CVS)
ENDIF(UNIX)
IF(CTEST_TEST_UPDATE_CVS)
- FIND_PACKAGE(CVS QUIET)
+ IF(EXISTS ${CMAKE_ROOT}/Modules/FindCVS.cmake)
+ FIND_PACKAGE(CVS QUIET)
+ ELSE(EXISTS ${CMAKE_ROOT}/Modules/FindCVS.cmake)
+ FIND_PROGRAM(CVS_EXECUTABLE NAMES cvs)
+ SET(CVS_FOUND ${CVS_EXECUTABLE})
+ ENDIF(EXISTS ${CMAKE_ROOT}/Modules/FindCVS.cmake)
ENDIF(CTEST_TEST_UPDATE_CVS)
IF(CTEST_TEST_UPDATE_CVS AND CVS_FOUND)
SET(CTestUpdateCVS_DIR "CTest UpdateCVS")