summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-09-15 14:27:38 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2014-09-15 14:27:38 (GMT)
commitb234836637d97b2d9cc837829c485ec87e64c5ce (patch)
tree294c854c5146ac45b5598f7220c36a4a4c7b8b6e /Tests/CMakeLists.txt
parent9edf6903e62f84a567db3938bb8fec3f19789545 (diff)
parentbe6a555d7ec9348575e3431bd6709f48dc959100 (diff)
downloadCMake-b234836637d97b2d9cc837829c485ec87e64c5ce.zip
CMake-b234836637d97b2d9cc837829c485ec87e64c5ce.tar.gz
CMake-b234836637d97b2d9cc837829c485ec87e64c5ce.tar.bz2
Merge topic 'vs-generator-platform'
be6a555d Tests: Test setting a generator platform in a toolchain file d506fee8 Tests: Use -A option to pass generator platform selection 11c9ddd6 ExternalProject: Use -A option to pass generator platform 29bd843e CTest: Use -A option to pass generator platform selection eb7d8156 cmake: Add -A option to specify a generator platform
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 3a0a8c7..5b336ce 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1988,7 +1988,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
# A test for ctest_build() with targets in subdirectories
set(ctest_configure_options)
if(CMAKE_GENERATOR_PLATFORM)
- list(APPEND ctest_configure_options -DCMAKE_GENERATOR_PLATFORM=${CMAKE_GENERATOR_PLATFORM})
+ list(APPEND ctest_configure_options -A ${CMAKE_GENERATOR_PLATFORM})
endif()
if(CMAKE_GENERATOR_TOOLSET)
list(APPEND ctest_configure_options -T ${CMAKE_GENERATOR_TOOLSET})