summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2022-09-27 15:05:53 (GMT)
committerBrad King <brad.king@kitware.com>2022-09-27 15:45:50 (GMT)
commit6c1337cb79341ec0f9aac617419b6311b6d601af (patch)
treeb7d19905b8138ef4b4e98c413cbf80e154f157fa /Tests/CMakeLists.txt
parent5faf145a5b31fc59bf3a9730efbf73d70faea50d (diff)
downloadCMake-6c1337cb79341ec0f9aac617419b6311b6d601af.zip
CMake-6c1337cb79341ec0f9aac617419b6311b6d601af.tar.gz
CMake-6c1337cb79341ec0f9aac617419b6311b6d601af.tar.bz2
Deprecate Visual Studio 11 2012 generator
Update documentation to mark the generator deprecated. Add a warning at the end of generation plus an option to turn off the warning.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 934f054..da87213 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -39,6 +39,13 @@ set(ENV{HOME} \"${TEST_HOME}\")
")
endif()
+# Suppress generator deprecation warnings in test suite.
+if(CMAKE_GENERATOR MATCHES "^Visual Studio 11 2012")
+ set(TEST_WARN_VS11_CODE "set(ENV{CMAKE_WARN_VS11} OFF)")
+else()
+ set(TEST_WARN_VS11_CODE "")
+endif()
+
# 3.9 or later provides a definitive answer to whether we are multi-config
# through a global property. Prior to 3.9, CMAKE_CONFIGURATION_TYPES being set
# is assumed to mean multi-config, but developers might modify it so it is