summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-12-14 17:36:25 (GMT)
committerBrad King <brad.king@kitware.com>2009-12-14 17:36:25 (GMT)
commit555fcbd2e2e5cafbb7cbf55b88093cc8f73a8009 (patch)
tree2ab8a9c2032c7ce1a9c27b31570e02cfd8b69af2 /Tests/CMakeLists.txt
parent126c93cddae95f46060f6d88af9c92dc6297f88d (diff)
downloadCMake-555fcbd2e2e5cafbb7cbf55b88093cc8f73a8009.zip
CMake-555fcbd2e2e5cafbb7cbf55b88093cc8f73a8009.tar.gz
CMake-555fcbd2e2e5cafbb7cbf55b88093cc8f73a8009.tar.bz2
Test FortranCInterface flag propagation
We create test FortranC.Flags to try passing per-language flags from a project into its FortranCInterface detect/verify checks. We wrap the compilers with scripts that enforce presence of expected flags.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index ac73f0d..e2e0921 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1485,6 +1485,15 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=CVS -P ${CMake_SOURCE_DIR}/Utilities/Rel
--build-two-config
--test-command testf)
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Fortran")
+
+ # FortranCInterface tests.
+ IF(UNIX)
+ CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/FortranC/Flags.cmake.in
+ ${CMAKE_CURRENT_BINARY_DIR}/FortranC/Flags.cmake @ONLY)
+ ADD_TEST(FortranC.Flags ${CMAKE_CMAKE_COMMAND} -P
+ ${CMAKE_CURRENT_BINARY_DIR}/FortranC/Flags.cmake)
+ LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/FortranC/Flags")
+ ENDIF()
ENDIF()
ENDIF()