summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Thursfield <sam.thursfield@codethink.co.uk>2016-01-19 17:43:05 (GMT)
committerBrad King <brad.king@kitware.com>2016-01-21 18:58:15 (GMT)
commit9b08c6233052fa1c3d393ee474c874f997491f7b (patch)
treebccb66d49c87c0f6533a2286ce235be0dcbcb5d2 /Tests/CMakeLists.txt
parentc13ed964012bcdf3765ada195db66930d6a0fcf9 (diff)
downloadCMake-9b08c6233052fa1c3d393ee474c874f997491f7b.zip
CMake-9b08c6233052fa1c3d393ee474c874f997491f7b.tar.gz
CMake-9b08c6233052fa1c3d393ee474c874f997491f7b.tar.bz2
FindPNG: Create an imported PNG::PNG target (#15911)
Imported targets are now the recommended way of dealing with external library dependencies. Add one for FindPNG and update documentation accordingly. Also add a test case activated by CMake_TEST_FindPNG.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 043b757..3cca77b 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1375,6 +1375,10 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
add_subdirectory(FindOpenSSL)
endif()
+ if(CMake_TEST_FindPNG)
+ add_subdirectory(FindPNG)
+ endif()
+
if(CMake_TEST_FindTIFF)
add_subdirectory(FindTIFF)
endif()