summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-03-08 18:02:36 (GMT)
committerBrad King <brad.king@kitware.com>2021-03-08 18:03:21 (GMT)
commit388eb83c098400cb63493896e12b05d685040147 (patch)
treef5e2f8f2a146a5c2dfd4098eca5cbb4cbf15025a /Tests/CMakeLists.txt
parentc0a33174970c7d0adb2d49287b0aab5aa9432e4e (diff)
downloadCMake-388eb83c098400cb63493896e12b05d685040147.zip
CMake-388eb83c098400cb63493896e12b05d685040147.tar.gz
CMake-388eb83c098400cb63493896e12b05d685040147.tar.bz2
Tests: Enable MAKE_SUPPORTS_SPACES tests with Ninja generators
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 987f54d..c3652fe 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -96,7 +96,7 @@ if(BUILD_TESTING)
# some old versions of make simply cannot handle spaces in paths
if (MAKE_IS_GNU OR
CMAKE_MAKE_PROGRAM MATCHES "nmake|gmake|wmake" OR
- CMAKE_GENERATOR MATCHES "Visual Studio|Xcode|Borland")
+ CMAKE_GENERATOR MATCHES "Visual Studio|Xcode|Borland|Ninja")
set(MAKE_SUPPORTS_SPACES 1)
else()
set(MAKE_SUPPORTS_SPACES 0)