summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-11-14 15:31:18 (GMT)
committerBrad King <brad.king@kitware.com>2019-11-14 15:57:42 (GMT)
commitd2e5e6ff1abec8b3b1579f122b7dcc89a35dbba4 (patch)
tree53e92d69536044321ac31d5543a6c426546b5aba /Tests/CMakeLists.txt
parent786954c4893565d8da27329201fd235e347e051d (diff)
downloadCMake-d2e5e6ff1abec8b3b1579f122b7dcc89a35dbba4.zip
CMake-d2e5e6ff1abec8b3b1579f122b7dcc89a35dbba4.tar.gz
CMake-d2e5e6ff1abec8b3b1579f122b7dcc89a35dbba4.tar.bz2
Tests: Organize Objective C/C++ test directories
Move them all under `Tests/ObjC` and `Tests/ObjCXX`.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt88
1 files changed, 2 insertions, 86 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index b29638b..57fa7fc 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2327,92 +2327,8 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
-P ${CMake_SOURCE_DIR}/Tests/CFBundleTest/VerifyResult.cmake)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/CFBundleTest")
- ADD_TEST_MACRO(ObjC++ ObjC++)
-
- add_test(Objective-C.simple-build-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C/simple-build-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C/simple-build-test"
- --build-two-config
- ${build_generator_args}
- --build-project simple-build-test
- --build-options ${build_options}
- --test-command simple-build-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C/simple-build-test")
-
- add_test(Objective-C.c-file-extension-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C/c-file-extension-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C/c-file-extension-test"
- --build-two-config
- ${build_generator_args}
- --build-project c-file-extension-test
- --build-options ${build_options}
- --test-command c-file-extension-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C/c-file-extension-test")
-
- add_test(Objective-C.cxx-file-extension-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C/cxx-file-extension-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C/cxx-file-extension-test"
- --build-two-config
- ${build_generator_args}
- --build-project cxx-file-extension-test
- --build-options ${build_options}
- --test-command cxx-file-extension-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C/cxx-file-extension-test")
-
- add_test(Objective-C.objc-file-extension-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C/objc-file-extension-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C/objc-file-extension-test"
- --build-two-config
- ${build_generator_args}
- --build-project objc-file-extension-test
- --build-options ${build_options}
- --test-command objc-file-extension-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMAKE_BINARY_DIR}/Tests/Objective-C/objc-file-extension-test")
-
- add_test(Objective-CXX.simple-build-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C++/simple-build-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C++/simple-build-test"
- --build-two-config
- ${build_generator_args}
- --build-project simple-build-test
- --build-options ${build_options}
- --test-command simple-build-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C++/simple-build-test")
-
- add_test(Objective-CXX.cxx-file-extension-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C++/cxx-file-extension-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C++/cxx-file-extension-test"
- --build-two-config
- ${build_generator_args}
- --build-project cxx-file-extension-test
- --build-options ${build_options}
- --test-command cxx-file-extension-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C++/cxx-file-extension-test")
-
- add_test(Objective-CXX.objcxx-file-extension-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C++/objcxx-file-extension-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C++/objcxx-file-extension-test"
- --build-two-config
- ${build_generator_args}
- --build-project objcxx-file-extension-test
- --build-options ${build_options}
- --test-command objcxx-file-extension-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMAKE_BINARY_DIR}/Tests/Objective-C++/objcxx-file-extension-test")
-
+ add_subdirectory(ObjC)
+ add_subdirectory(ObjCXX)
endif ()
endif ()