summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-06-25 11:15:25 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-06-25 11:15:33 (GMT)
commit1009fd18604e7670838ed28798b83312eff1b0f0 (patch)
tree021b1f179dffec0b36975a7d91defec173a38770 /Tests/CMakeLists.txt
parentdba8086f58484f545c053a3c5175ec75df8a817f (diff)
parent56e89e50d3dc4a971ed9d7195834e1233658c08e (diff)
downloadCMake-1009fd18604e7670838ed28798b83312eff1b0f0.zip
CMake-1009fd18604e7670838ed28798b83312eff1b0f0.tar.gz
CMake-1009fd18604e7670838ed28798b83312eff1b0f0.tar.bz2
Merge topic 'matlab-if'
56e89e50d3 FindMatlab: simplify several if()-constructs 51bcdeb17f Tests: simplify checks for Matlab variables being set Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !3472
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index b5557ad..b766838 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1591,16 +1591,16 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
# CMake_TEST_FindMatlab_ROOT_DIR: indicates an optional root directory for Matlab, allows to select a version.
# CMake_TEST_FindMatlab_MCR: indicates the MCR is installed
# CMake_TEST_FindMatlab_MCR_ROOT_DIR: indicates an optional root directory for the MCR, required on Linux
- if(CMake_TEST_FindMatlab OR (NOT "${CMake_TEST_FindMatlab_ROOT_DIR}" STREQUAL "") OR
- CMake_TEST_FindMatlab_MCR OR (NOT "${CMake_TEST_FindMatlab_MCR_ROOT_DIR}" STREQUAL ""))
+ if(CMake_TEST_FindMatlab OR CMake_TEST_FindMatlab_ROOT_DIR OR
+ CMake_TEST_FindMatlab_MCR OR CMake_TEST_FindMatlab_MCR_ROOT_DIR)
set(FindMatlab_additional_test_options )
- if(CMake_TEST_FindMatlab_MCR OR NOT "${CMake_TEST_FindMatlab_MCR_ROOT_DIR}" STREQUAL "")
+ if(CMake_TEST_FindMatlab_MCR OR CMake_TEST_FindMatlab_MCR_ROOT_DIR)
set(FindMatlab_additional_test_options -DIS_MCR=TRUE)
endif()
- if(NOT "${CMake_TEST_FindMatlab_ROOT_DIR}" STREQUAL "")
+ if(CMake_TEST_FindMatlab_ROOT_DIR)
set(FindMatlab_additional_test_options ${FindMatlab_additional_test_options} "-DMatlab_ROOT_DIR=${CMake_TEST_FindMatlab_ROOT_DIR}")
endif()
- if(NOT "${CMake_TEST_FindMatlab_MCR_ROOT_DIR}" STREQUAL "")
+ if(CMake_TEST_FindMatlab_MCR_ROOT_DIR)
set(FindMatlab_additional_test_options ${FindMatlab_additional_test_options} "-DMCR_ROOT:FILEPATH=${CMake_TEST_FindMatlab_MCR_ROOT_DIR}")
endif()
set(FindMatlab.basic_checks_BUILD_OPTIONS ${FindMatlab_additional_test_options})