summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-12-02 22:41:20 (GMT)
committerBrad King <brad.king@kitware.com>2021-12-02 23:06:39 (GMT)
commit13a7ae2194d44f955712d65fecf0b741049da00e (patch)
tree6dc6cd3a86339ee588aab1860f9a165bd5f319a0 /Tests/CMakeLists.txt
parenteeaf1e10cb5f736692136cb31c4ffbb717599917 (diff)
downloadCMake-13a7ae2194d44f955712d65fecf0b741049da00e.zip
CMake-13a7ae2194d44f955712d65fecf0b741049da00e.tar.gz
CMake-13a7ae2194d44f955712d65fecf0b741049da00e.tar.bz2
VS: Revert "Add missing label in C# project-build events"
Revert commit b284a21fee (VS: Add missing label in C# project-build events, 2021-09-03, v3.22.0-rc1~156^2). The change broke cases using multiple successful custom commands. Revert it pending further investigation into the interaction of the generated script code with `Microsoft.Common.CurrentVersion.targets`, and whether this is needed for all managed projects or just C# projects. Also add a test covering the case that was broken. Fixes: #22964 Issue: #21440
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index ecb54c7..36bbc62 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2236,6 +2236,7 @@ if(BUILD_TESTING)
if(NOT "${CMAKE_GENERATOR}" MATCHES "Visual Studio 9 "
AND NOT CMAKE_GENERATOR_TOOLSET)
ADD_TEST_MACRO(VSWindowsFormsResx VSWindowsFormsResx)
+ ADD_TEST_MACRO(VSManagedCustomCommand)
endif()
add_test(VSExternalInclude ${CMAKE_CTEST_COMMAND}