summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2024-01-31 14:01:36 (GMT)
committerKitware Robot <kwrobot@kitware.com>2024-01-31 14:01:45 (GMT)
commit2a008138420b0a2cc867f5d3e47accc7d2fda5e0 (patch)
tree019a7b2fa05325b311e172e0460f4441604faf3e /Tests/CMakeLists.txt
parenteb9124bd195817efcc17bf8d5b44d487efa0046b (diff)
parent77c4d2f9a213f0c6bda0fb78238d621ecbb3676d (diff)
downloadCMake-2a008138420b0a2cc867f5d3e47accc7d2fda5e0.zip
CMake-2a008138420b0a2cc867f5d3e47accc7d2fda5e0.tar.gz
CMake-2a008138420b0a2cc867f5d3e47accc7d2fda5e0.tar.bz2
Merge topic 'xcode-pch-swift-cxx'
77c4d2f9a2 Xcode: Fix PCH support with Swift & C++ Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !9203
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index a1619ec..a7a456c 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -412,6 +412,7 @@ if(BUILD_TESTING)
PASS_REGULAR_EXPRESSION "CMake Error at CMakeLists.txt:3 \\(add_executable\\):[ \r\n]*Cannot find source file:[ \r\n]*DoesNotExist/MissingSourceFile.c")
if(CMake_TEST_Swift)
ADD_TEST_MACRO(SwiftOnly SwiftOnly)
+ ADD_TEST_MACRO(SwiftMixPCH SwiftMixPCH)
if(CMake_TEST_XCODE_SWIFT)
ADD_TEST_MACRO(SwiftMix SwiftMix)
endif()