summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2020-09-14 18:48:07 (GMT)
committerKyle Edwards <kyle.edwards@kitware.com>2020-09-23 18:10:40 (GMT)
commit4c6e5cd0fae57684411d6bf814b4fcc4434c1f50 (patch)
tree64307ab060a02102e6861008fba72340ad2ba3ea /Tests/CMakeLists.txt
parent41e223deb37767d9beb8c4462b8b8df88ba2dedf (diff)
downloadCMake-4c6e5cd0fae57684411d6bf814b4fcc4434c1f50.zip
CMake-4c6e5cd0fae57684411d6bf814b4fcc4434c1f50.tar.gz
CMake-4c6e5cd0fae57684411d6bf814b4fcc4434c1f50.tar.bz2
Tests: Add some basic tests for CMake GUI
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index ee3ac3d..9aa401d 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -3532,6 +3532,10 @@ if(BUILD_TESTING)
add_subdirectory(CMakeTests)
endif()
+ if(BUILD_QtDialog AND CMake_TEST_GUI AND NOT CMake_TEST_EXTERNAL_CMAKE)
+ add_subdirectory(CMakeGUI)
+ endif()
+
# If this is not an in-source build, provide a target to wipe out
# all the test build directories. This must come at the end after
# all the above logic has finished adding to TEST_BUILD_DIRS