summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-12-03 14:09:04 (GMT)
committerBrad King <brad.king@kitware.com>2021-12-03 14:09:04 (GMT)
commit69419c58709e8a89dbb893295ac09c5f75cd25f3 (patch)
tree6510704a1b0cf57616e7516a51469bfba49739b4 /Tests/CMakeLists.txt
parent67cbfed81981a25aa56a3d05a267c1acf6ea5781 (diff)
downloadCMake-69419c58709e8a89dbb893295ac09c5f75cd25f3.zip
CMake-69419c58709e8a89dbb893295ac09c5f75cd25f3.tar.gz
CMake-69419c58709e8a89dbb893295ac09c5f75cd25f3.tar.bz2
ci: Enable more VS tests that use managed code
A couple of VS tests were conditioned on `NOT CMAKE_GENERATOR_TOOLSET`, but in CI jobs with VS we always set `CMAKE_GENERATOR_TOOLSET`. Make the condition specific to excluding the `v90` toolset, which was its original intention anyway.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 36bbc62..8b38080 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2234,7 +2234,7 @@ if(BUILD_TESTING)
endif()
if(NOT "${CMAKE_GENERATOR}" MATCHES "Visual Studio 9 "
- AND NOT CMAKE_GENERATOR_TOOLSET)
+ AND NOT CMAKE_GENERATOR_TOOLSET STREQUAL "v90")
ADD_TEST_MACRO(VSWindowsFormsResx VSWindowsFormsResx)
ADD_TEST_MACRO(VSManagedCustomCommand)
endif()