summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-03-04 20:50:16 (GMT)
committerBrad King <brad.king@kitware.com>2021-03-08 18:03:21 (GMT)
commit7621861f30992bdaddb66a7f3e5dce6eec4545bd (patch)
tree1da0732928fb86d3d8b7b4777052b062f9735152 /Tests/CMakeLists.txt
parent388eb83c098400cb63493896e12b05d685040147 (diff)
downloadCMake-7621861f30992bdaddb66a7f3e5dce6eec4545bd.zip
CMake-7621861f30992bdaddb66a7f3e5dce6eec4545bd.tar.gz
CMake-7621861f30992bdaddb66a7f3e5dce6eec4545bd.tar.bz2
Tests: Update LibName to cover spaces in shared library name
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index c3652fe..3a05317 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -828,6 +828,8 @@ if(BUILD_TESTING)
${build_generator_args}
--build-project LibName
--build-exe-dir "${CMake_BINARY_DIR}/Tests/LibName/lib"
+ --build-options
+ -DMAKE_SUPPORTS_SPACES=${MAKE_SUPPORTS_SPACES}
--test-command foobar
)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/LibName")