summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGregor Jasny <gjasny@googlemail.com>2021-06-10 14:09:04 (GMT)
committerGregor Jasny <gjasny@googlemail.com>2021-06-10 20:24:31 (GMT)
commit8dcdd4351fd6236f05fbb613cd805fb41d2a1865 (patch)
tree6cd225015d42ec58e9d7a57695adb6101b463e2c /Tests/CMakeLists.txt
parent2086b938a7b60ce07a28840240de82687b769575 (diff)
downloadCMake-8dcdd4351fd6236f05fbb613cd805fb41d2a1865.zip
CMake-8dcdd4351fd6236f05fbb613cd805fb41d2a1865.tar.gz
CMake-8dcdd4351fd6236f05fbb613cd805fb41d2a1865.tar.bz2
Tests: recognize Xcode 13 linker warning
The linker shipped with Xcode 13 changed the architecture mismatch linker warning into: ``` ld: warning: ignoring file libfoo.a, building for macOS-x86_64 but attempting to link with file built for macOS-i386 ```
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 57d75e1..2f9b7ff 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -538,7 +538,7 @@ if(BUILD_TESTING)
if(CTEST_TEST_OSX_ARCH)
ADD_TEST_MACRO(Architecture Architecture)
set_tests_properties(Architecture PROPERTIES
- PASS_REGULAR_EXPRESSION "(file is not of required architecture|does not match cputype|not the architecture being linked)")
+ PASS_REGULAR_EXPRESSION "(file is not of required architecture|does not match cputype|not the architecture being linked|but attempting to link with file built for)")
endif()
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})