summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-02-08 16:49:27 (GMT)
committerBrad King <brad.king@kitware.com>2023-02-08 16:49:27 (GMT)
commitd7f440c5dbe787ccf96da490ad813a897c146498 (patch)
treef6ff1215509899d6d17dbca52eb23cad65a37b32 /Tests/CMakeLists.txt
parent507dcaf5639c8a3e0ae4aeb2792b6926861aebd3 (diff)
downloadCMake-d7f440c5dbe787ccf96da490ad813a897c146498.zip
CMake-d7f440c5dbe787ccf96da490ad813a897c146498.tar.gz
CMake-d7f440c5dbe787ccf96da490ad813a897c146498.tar.bz2
Deprecate Visual Studio 9 2008 generator
Update documentation to mark the generator deprecated. Add a warning at the end of generation plus an option to turn off the warning.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index c22f704..38e0460 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -40,10 +40,12 @@ set(ENV{HOME} \"${TEST_HOME}\")
endif()
# Suppress generator deprecation warnings in test suite.
-if(CMAKE_GENERATOR MATCHES "^Visual Studio 11 2012")
- set(TEST_WARN_VS11_CODE "set(ENV{CMAKE_WARN_VS11} OFF)")
+if(CMAKE_GENERATOR MATCHES "^Visual Studio 9 2008")
+ set(TEST_WARN_VS_CODE "set(ENV{CMAKE_WARN_VS9} OFF)")
+elseif(CMAKE_GENERATOR MATCHES "^Visual Studio 11 2012")
+ set(TEST_WARN_VS_CODE "set(ENV{CMAKE_WARN_VS11} OFF)")
else()
- set(TEST_WARN_VS11_CODE "")
+ set(TEST_WARN_VS_CODE "")
endif()
# 3.9 or later provides a definitive answer to whether we are multi-config