summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-01-04 20:44:01 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2011-01-04 20:44:01 (GMT)
commitf1d7a5600fab0d3cd314fd9ae059010ea6f7e5b9 (patch)
tree864eea994d526a99eb3c10c449968d50a292d2da /Tests/CMakeLists.txt
parentda9b5fe4b521bbb9d873cfa3ebc9c67c0d6b66bf (diff)
parent8c7b19d35ee81afac57fe623217578191f4d034c (diff)
downloadCMake-f1d7a5600fab0d3cd314fd9ae059010ea6f7e5b9.zip
CMake-f1d7a5600fab0d3cd314fd9ae059010ea6f7e5b9.tar.gz
CMake-f1d7a5600fab0d3cd314fd9ae059010ea6f7e5b9.tar.bz2
Merge topic 'add_preprocessor_def_vs2010_resources'
8c7b19d Only run resource test for MSVC compilers. 753e208 Disable incremental testing for this test, it crashes vs9 linker. 16e7d4b Add flags to resource builds on vs 2010 with a test.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 289e632..911b247 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -131,6 +131,9 @@ IF(BUILD_TESTING)
ADD_TEST_MACRO(TarTest TarTest)
ADD_TEST_MACRO(SystemInformation SystemInformation)
ADD_TEST_MACRO(MathTest MathTest)
+ IF(MSVC)
+ ADD_TEST_MACRO(VSResource VSResource)
+ ENDIF()
ADD_TEST_MACRO(Simple Simple)
ADD_TEST_MACRO(PreOrder PreOrder)
ADD_TEST_MACRO(MissingSourceFile MissingSourceFile)
@@ -246,7 +249,6 @@ IF(BUILD_TESTING)
--test-command Simple)
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Simple_CodeBlocksGenerator")
ENDIF ("${cmakeOutput}" MATCHES CodeBlocks)
-
# check for the KDevelop3 generator
IF ("${cmakeOutput}" MATCHES KDevelop3)
ADD_TEST(Simple_KDevelop3Generator ${CMAKE_CTEST_COMMAND}