summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2010-09-14 17:31:10 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2010-09-14 17:31:10 (GMT)
commit6580f5de996e99e090ccf9fefa5a2c5d14694478 (patch)
tree48ca163d80c1f13cf7b39b11a579e54afb375289 /Tests/CMakeLists.txt
parentee66f2127167517bcaba326967bbbbcdffa97788 (diff)
parenta6b5ead62fb4e69c053d752570f4c8af24e41857 (diff)
downloadCMake-6580f5de996e99e090ccf9fefa5a2c5d14694478.zip
CMake-6580f5de996e99e090ccf9fefa5a2c5d14694478.tar.gz
CMake-6580f5de996e99e090ccf9fefa5a2c5d14694478.tar.bz2
Merge topic 'improve-missing-source-file-error'
a6b5ead Report missing source files with context of target
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index eb86a34..5e88b5c 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -129,6 +129,9 @@ IF(BUILD_TESTING)
ADD_TEST_MACRO(MathTest MathTest)
ADD_TEST_MACRO(Simple Simple)
ADD_TEST_MACRO(PreOrder PreOrder)
+ ADD_TEST_MACRO(MissingSourceFile MissingSourceFile)
+ SET_TESTS_PROPERTIES(MissingSourceFile PROPERTIES
+ PASS_REGULAR_EXPRESSION "CMake Error at CMakeLists.txt:3 \\(add_executable\\):[ \r\n]*Cannot find source file \"MissingSourceFile.c\"")
ADD_TEST_MACRO(COnly COnly)
ADD_TEST_MACRO(CxxOnly CxxOnly)
ADD_TEST_MACRO(IPO COnly/COnly)