summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2023-09-19 13:49:19 (GMT)
committerKyle Edwards <kyle.edwards@kitware.com>2023-09-22 13:30:52 (GMT)
commita7534c31e6f9309ec2a2418d8b6c167bf1be150d (patch)
tree70ad9a993b1a3ffd13b9a7d64bc80fbf76d89f49 /Tests/CMakeLists.txt
parent59b0ae6b244d2def6a3cdd8bb96868b3b2c74ccb (diff)
downloadCMake-a7534c31e6f9309ec2a2418d8b6c167bf1be150d.zip
CMake-a7534c31e6f9309ec2a2418d8b6c167bf1be150d.tar.gz
CMake-a7534c31e6f9309ec2a2418d8b6c167bf1be150d.tar.bz2
Tests: Update tests to run in multi-config generators
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 7a71c0a..cd9cc17 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -142,6 +142,10 @@ if(BUILD_TESTING)
)
endif()
+ if(_isMultiConfig)
+ set(test_options -C Debug)
+ endif()
+
# Look for git to use for tests.
find_program(GIT_EXECUTABLE NAMES git)