summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorZack Galbreath <zack.galbreath@kitware.com>2023-07-24 14:00:11 (GMT)
committerBrad King <brad.king@kitware.com>2023-07-25 13:09:56 (GMT)
commitb7c871f7459ef18f863d8fea15eae7e7f85a9d34 (patch)
tree15e3166e9af0d262e2b92cd793bb739a422e3cab /Tests/CMakeLists.txt
parenteace51a20cc9597878e92d96da97492af99d95c1 (diff)
downloadCMake-b7c871f7459ef18f863d8fea15eae7e7f85a9d34.zip
CMake-b7c871f7459ef18f863d8fea15eae7e7f85a9d34.tar.gz
CMake-b7c871f7459ef18f863d8fea15eae7e7f85a9d34.tar.bz2
ctest: Update ctest_submit for CDash behavior change
open.cdash.org was recently upgraded in preparation for the release of CDash v3.2.0. This upgrade brought a change in behavior where CDash now responds with HTTP 400 (bad request) rather than HTTP 200 (OK) for MD5 checksum mismatches during submission time. This commit removes our usage of CURLOPT_FAILONERROR in cmCTestSubmitHandler.cxx This was necessary to pass along the contents of the request body ("md5 mismatch") in cases where the web server (CDash) responds with an error status (400). Fixes: #25121
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index c22f704..09dfa7b 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -3304,7 +3304,7 @@ if(BUILD_TESTING)
"${CMake_BINARY_DIR}/Tests/CTestTestChecksum/testOutput.log"
)
set_tests_properties(CTestTestChecksum PROPERTIES PASS_REGULAR_EXPRESSION
- "Submission failed: Checksum failed for file")
+ "md5 mismatch")
# these tests take a long time, make sure they have it
# if timeouts have not already been set