summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorM. Konrad <konrad@ikp.tu-darmstadt.de>2011-03-11 07:47:15 (GMT)
committerEric NOULARD <eric.noulard@gmail.com>2011-03-11 07:47:15 (GMT)
commitbf7066c6ce992cdb8d663de8bc1794284d953769 (patch)
treed568e9f0ae54e18c99a2b8f96d998a5e40cf279a /Tests/CMakeLists.txt
parent8def3f59495208b44ae2b94d177c9cccd5bb1cca (diff)
downloadCMake-bf7066c6ce992cdb8d663de8bc1794284d953769.zip
CMake-bf7066c6ce992cdb8d663de8bc1794284d953769.tar.gz
CMake-bf7066c6ce992cdb8d663de8bc1794284d953769.tar.bz2
CPackDeb add Component Support to DEB generator fix #0011655
Contribution by Martin Konrad Signed-off-by: Eric NOULARD <eric.noulard@gmail.com>
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 7235e1d..6da06f6 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -572,6 +572,12 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
if (RPMBUILD)
list(APPEND GENLST "RPM")
endif(RPMBUILD)
+ if (CMAKE_SYSTEM_NAME MATCHES "Linux")
+ find_program(DPKG NAMES dpkg)
+ if (DPKG)
+ list(APPEND GENLST "DEB")
+ endif(DPKG)
+ endif(CMAKE_SYSTEM_NAME MATCHES "Linux")
# set up list of component packaging ways
list(APPEND CWAYLST "default")
list(APPEND CWAYLST "OnePackPerGroup")