summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-06-24 17:53:27 (GMT)
committerBrad King <brad.king@kitware.com>2014-06-24 17:54:51 (GMT)
commit1bd4e006aa8ae44d3d7777bcf7da56ed7be185fd (patch)
treeabea325fedf72bfe6c8b7b3ef8463a5a3e82e2c6 /Tests/CMakeLists.txt
parentc196b3ca023aeddfa8851477fc34a068bdd7d26f (diff)
downloadCMake-1bd4e006aa8ae44d3d7777bcf7da56ed7be185fd.zip
CMake-1bd4e006aa8ae44d3d7777bcf7da56ed7be185fd.tar.gz
CMake-1bd4e006aa8ae44d3d7777bcf7da56ed7be185fd.tar.bz2
Tests: Fix CMAKE_TESTS_CDASH_SERVER parsing
Allow the value to end without a slash and have an empty server path component. This is needed to match "http://open.cdash.org" correctly.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 273a541..e443509 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2549,7 +2549,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
if (CMAKE_TESTS_CDASH_SERVER)
- set(regex "^([^:]+)://([^/]+)(/.*)$")
+ set(regex "^([^:]+)://([^/]+)(.*)$")
if ("${CMAKE_TESTS_CDASH_SERVER}" MATCHES "${regex}")
set(protocol "${CMAKE_MATCH_1}")