summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-06-05 15:00:57 (GMT)
committerBen Boeckel <ben.boeckel@kitware.com>2014-06-05 16:44:19 (GMT)
commit3495ab0a81a8f7404d69d94856245e266a568799 (patch)
tree0a5bacfe61f366954e114b826a9f334a72cd7b80 /Tests/CMakeLists.txt
parent2a1b2d848693a3860f8e5f179b6c97f8c56abede (diff)
downloadCMake-3495ab0a81a8f7404d69d94856245e266a568799.zip
CMake-3495ab0a81a8f7404d69d94856245e266a568799.tar.gz
CMake-3495ab0a81a8f7404d69d94856245e266a568799.tar.bz2
tests: update unused variable test expected output
The expected output is now a relative path, not a full path. Update the pass/fail detection accordingly.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 05442a1..eeb9e7a 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1820,9 +1820,9 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
--build-options ${build_options}
"--warn-unused-vars")
set_tests_properties(WarnUnusedUnusedViaUnset PROPERTIES
- PASS_REGULAR_EXPRESSION "CMake Warning .*VariableUnusedViaUnset.CMakeLists.txt:7 \\(set\\):")
+ PASS_REGULAR_EXPRESSION "CMake Warning \\(dev\\) at CMakeLists.txt:7 \\(set\\):")
set_tests_properties(WarnUnusedUnusedViaUnset PROPERTIES
- FAIL_REGULAR_EXPRESSION "CMake Warning .*VariableUnusedViaUnset.CMakeLists.txt:5 \\(set\\):")
+ FAIL_REGULAR_EXPRESSION "CMakeLists.txt:5 \\(set\\):")
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/WarnUnusedUnusedViaUnset")
if("${CMAKE_GENERATOR}" MATCHES "Makefile" AND NOT WIN32)