summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-05-31 14:11:51 (GMT)
committerBrad King <brad.king@kitware.com>2017-05-31 14:11:51 (GMT)
commit52d0983a88a28709ced63dc0a9ad955d75cdbfe8 (patch)
treef1a0e10fe04904ba9d7f65210651ab350a7c042b /Tests/CMakeLists.txt
parentde16ff3e58b0518c707ae877e80b6f81e26a4326 (diff)
downloadCMake-52d0983a88a28709ced63dc0a9ad955d75cdbfe8.zip
CMake-52d0983a88a28709ced63dc0a9ad955d75cdbfe8.tar.gz
CMake-52d0983a88a28709ced63dc0a9ad955d75cdbfe8.tar.bz2
Tests: Skip BootstrapTest if testing external CMake
If we are not actually building CMake then we should not run the `BootstrapTest` (which builds CMake).
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 21fe641..2c05789 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -3110,6 +3110,9 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
endif ()
endif ()
+ if(CMake_TEST_EXTERNAL_CMAKE)
+ set(CMAKE_SKIP_BOOTSTRAP_TEST 1)
+ endif()
if("${CMAKE_GENERATOR}" MATCHES Xcode)
set(CMAKE_SKIP_BOOTSTRAP_TEST 1)
endif()