summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-22 13:07:14 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2013-10-22 13:07:14 (GMT)
commit6384f1683ab49890fad9a6b60bdbcaafd0bc2df7 (patch)
tree26fe7b2d9b138b2cbb02f14771fe35d2f32c29fd /Tests/CMakeLists.txt
parente71a5e39826895af737b907f23b66412602a7f50 (diff)
parenta8226e91d75e595248a176966f3f645203f12072 (diff)
downloadCMake-6384f1683ab49890fad9a6b60bdbcaafd0bc2df7.zip
CMake-6384f1683ab49890fad9a6b60bdbcaafd0bc2df7.tar.gz
CMake-6384f1683ab49890fad9a6b60bdbcaafd0bc2df7.tar.bz2
Merge topic 'remove-cmake-i-wizard'
a8226e9 cmake: Drop support for "-i" wizard mode
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 198ce04..b9c99e3 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2526,11 +2526,10 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
)
endif()
- add_test(CMakeWizardTest ${CMAKE_CMAKE_COMMAND}
- -D build_dir:STRING=${CMAKE_CURRENT_BINARY_DIR}/CMakeWizardTest
- -D source_dir:STRING=${CMAKE_CURRENT_SOURCE_DIR}/Tutorial/Step3
- -D CMAKE_CTEST_COMMAND:STRING=${CMAKE_CTEST_COMMAND}
- -P ${CMAKE_CURRENT_SOURCE_DIR}/CMakeWizardTest.cmake)
+ add_test(NAME CMakeWizardTest COMMAND cmake -i)
+ set_property(TEST CMakeWizardTest PROPERTY PASS_REGULAR_EXPRESSION
+ "The \"cmake -i\" wizard mode is no longer supported.")
+
# If the cache variable CMAKE_CONTRACT_PROJECTS is set
# then the dashboard will run a contract with CMake test of that
# name. For example CMAKE_CONTRACT_PROJECTS = vtk542 would run