summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-01-09 14:37:17 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2014-01-09 14:37:17 (GMT)
commit69c366a28178027a5cf2629c0240d1709ae9ab55 (patch)
treefe61369dffe946ccb6b17830994d901e3af4662c /Tests/CMakeLists.txt
parentf3a9eb45605638b42ca431731080875470cc229a (diff)
parentbe0458c5620d611a772fd3a25312cf5ae6cb492c (diff)
downloadCMake-69c366a28178027a5cf2629c0240d1709ae9ab55.zip
CMake-69c366a28178027a5cf2629c0240d1709ae9ab55.tar.gz
CMake-69c366a28178027a5cf2629c0240d1709ae9ab55.tar.bz2
Merge topic 'optional-install'
be0458c InstallRules: added new variable to disable generation of install rules
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 78dddd3..7969078 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -742,6 +742,19 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
--test-command ${SimpleInstallInstallDir}/MyTest/bin/SimpleInstExeS2)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/SimpleInstallS2")
+ set(MissingInstallInstallDir
+ "${CMake_BINARY_DIR}/Tests/MissingInstall/InstallDirectory")
+ add_test(MissingInstall ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/MissingInstall"
+ "${CMake_BINARY_DIR}/Tests/MissingInstall"
+ ${build_generator_args}
+ --build-project TestMissingInstall
+ --build-two-config
+ --build-options ${build_options}
+ "-DCMAKE_INSTALL_PREFIX:PATH=${MissingInstallInstallDir}")
+ list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/MissingInstall")
+
# By default, run the CPackComponents test if the CTEST_TEST_CPACK
# option is ON:
#