summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-05-23 13:47:44 (GMT)
committerBrad King <brad.king@kitware.com>2014-05-23 14:30:39 (GMT)
commit9afcecaf32acb4333b33d46522f98457bfa8856d (patch)
treec27da3ad5fcafddaf930e517b05c5c392e1e92af /Tests/CMakeLists.txt
parent8ae05b420e513252d1fd68dc6085d8dd92f3e624 (diff)
downloadCMake-9afcecaf32acb4333b33d46522f98457bfa8856d.zip
CMake-9afcecaf32acb4333b33d46522f98457bfa8856d.tar.gz
CMake-9afcecaf32acb4333b33d46522f98457bfa8856d.tar.bz2
Tests: Try to make CTestTestTimeout more robust
Write to the timeout test log file before sleeping and flush to be sure it is created. Move the check that the after-sleep line is not written out to the ctest script. Rename the CheckChild test to TestSleep since it no longer checks. Do not try to read the log file if it does not exist.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 5014ef3..8d2b7fc 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2394,7 +2394,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
--output-log "${CMake_BINARY_DIR}/Tests/CTestTestTimeout/testOutput.log"
)
set_tests_properties(CTestTestTimeout PROPERTIES
- PASS_REGULAR_EXPRESSION "TestTimeout *\\.+ *\\*\\*\\*Timeout.*CheckChild *\\.+ *Passed")
+ PASS_REGULAR_EXPRESSION "TestTimeout *\\.+ *\\*\\*\\*Timeout.*TestSleep *\\.+ *Passed.*timeout correctly killed child")
add_test(
NAME CTestTestRerunFailed