summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@gmail.com>2023-06-29 13:11:12 (GMT)
committerMarc Chevrier <marc.chevrier@gmail.com>2023-06-29 15:07:56 (GMT)
commit9b45210b052c7c81ab84313c4a3b537e66c2a7b7 (patch)
tree91a232e58d2f8cdb52c7ed8c81c6ae49e861b8fa /Tests/CMakeLists.txt
parentc24be2ffe726f876a5b4c235848b24bc3fe5f5e2 (diff)
downloadCMake-9b45210b052c7c81ab84313c4a3b537e66c2a7b7.zip
CMake-9b45210b052c7c81ab84313c4a3b537e66c2a7b7.tar.gz
CMake-9b45210b052c7c81ab84313c4a3b537e66c2a7b7.tar.bz2
FindPython: Add tests for IronPython v3
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 914ebce..2a7c839 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1557,15 +1557,17 @@ if(BUILD_TESTING)
endif()
if(CMake_TEST_FindPython_IronPython)
set(CMake_TEST_FindPython2_IronPython TRUE)
+ set(CMake_TEST_FindPython3_IronPython TRUE)
endif()
if(CMake_TEST_FindPython_PyPy)
set(CMake_TEST_FindPython2_PyPy TRUE)
set(CMake_TEST_FindPython3_PyPy TRUE)
endif()
- if(CMake_TEST_FindPython2 OR CMake_TEST_FindPython2
+ if(CMake_TEST_FindPython2 OR CMake_TEST_FindPython3
OR CMake_TEST_FindPython2_SABIModule OR CMake_TEST_FindPython3_SABIModule
OR CMake_TEST_FindPython2_NumPy OR CMake_TEST_FindPython3_NumPy
- OR CMake_TEST_FindPython3_Conda OR CMake_TEST_FindPython2_IronPython
+ OR CMake_TEST_FindPython3_Conda
+ OR CMake_TEST_FindPython2_IronPython OR CMake_TEST_FindPython3_IronPython
OR CMake_TEST_FindPython2_PyPy OR CMake_TEST_FindPython3_PyPy)
if (CMake_TEST_FindPython2 AND CMAKE_SYSTEM_NAME MATCHES "Linux|Darwin")
set(CMake_TEST_FindPython2_SABIModule TRUE)