summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2012-05-09 21:47:37 (GMT)
committerStephen Kelly <steveire@gmail.com>2012-06-04 21:42:37 (GMT)
commitdb839bec7d076b54c5e9ad0d19386a26557a509e (patch)
treea9ad4797209348cc105d19e01eacf5c25ddff8bf /Tests/CMakeLists.txt
parent8778357898327c1e4893d8dc140fc0e63331e36b (diff)
downloadCMake-db839bec7d076b54c5e9ad0d19386a26557a509e.zip
CMake-db839bec7d076b54c5e9ad0d19386a26557a509e.tar.gz
CMake-db839bec7d076b54c5e9ad0d19386a26557a509e.tar.bz2
Make the CMAKE_EXPORT_COMPILE_COMMANDS option work with Ninja.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 5972c19..ffa5bcb 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -47,7 +47,7 @@ CONFIGURE_FILE(${CMake_SOURCE_DIR}/Tests/EnforceConfig.cmake.in
# Testing
IF(BUILD_TESTING)
- IF("${CMAKE_TEST_GENERATOR}" MATCHES "Unix Makefiles")
+ IF("${CMAKE_TEST_GENERATOR}" MATCHES "Unix Makefiles" OR "${CMAKE_TEST_GENERATOR}" MATCHES Ninja)
SET(TEST_CompileCommandOutput 1)
ENDIF()