summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-03-21 16:56:35 (GMT)
committerBrad King <brad.king@kitware.com>2019-03-21 16:57:38 (GMT)
commitddad70c8a48eb90493760b7fa3d3850235ad451a (patch)
tree2f02773fdc6a10e6aa1f26c47175e9c5aef9d3b1 /Tests/CMakeLists.txt
parentf7dca1fc97c08146da33a2d6a3ba22ad8e08d94a (diff)
downloadCMake-ddad70c8a48eb90493760b7fa3d3850235ad451a.zip
CMake-ddad70c8a48eb90493760b7fa3d3850235ad451a.tar.gz
CMake-ddad70c8a48eb90493760b7fa3d3850235ad451a.tar.bz2
Tests: Run GHS tests in a separate ctest process
These tests use a different compiler than the rest of the test suite. Isolate the rest of our tests from their environment.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 01f8226..a59b6eb 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2316,6 +2316,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
--build-generator "Green Hills MULTI"
--build-project test
--build-config $<CONFIGURATION>
+ --force-new-ctest-process
--build-options ${ghs_target_arch} ${ghs_toolset_name} ${ghs_toolset_root} ${ghs_target_platform}
${ghs_os_root} ${ghs_os_dir} ${ghs_bsp_name} ${_ghs_build_opts} ${_ghs_toolset_extra}
${_ghs_test_command}