summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Pfeifer <daniel@pfeifer-mail.de>2016-10-21 16:18:18 (GMT)
committerDaniel Pfeifer <daniel@pfeifer-mail.de>2016-10-21 16:22:44 (GMT)
commite3770c56a8ef6b20f473556a1ca29ea6e0f51f7f (patch)
treeb98a6760e5d2327eeb05616e7816d48334baf104 /Tests/CMakeLists.txt
parent1e555a44aa4e3d40bca2f88915c9f957098e5a55 (diff)
downloadCMake-e3770c56a8ef6b20f473556a1ca29ea6e0f51f7f.zip
CMake-e3770c56a8ef6b20f473556a1ca29ea6e0f51f7f.tar.gz
CMake-e3770c56a8ef6b20f473556a1ca29ea6e0f51f7f.tar.bz2
BootstrapTest: Use --parallel=... argument.
Determine the number of processors and provide it to the bootstrap script. Also make sure this test does not run parallel with other tests.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 7df9403..5d72e5c 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -3081,8 +3081,8 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
-P ${CMAKE_CURRENT_SOURCE_DIR}/BootstrapTest.cmake
)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/BootstrapTest")
- # Make this test run early during parallel execution
- set_tests_properties(BootstrapTest PROPERTIES COST 5000)
+ # This test will use all processors.
+ set_tests_properties(BootstrapTest PROPERTIES RUN_SERIAL 1)
# provide more time for the bootstrap test
get_test_property(BootstrapTest TIMEOUT PREVIOUS_TIMEOUT)