summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-11-15 14:07:42 (GMT)
committerBrad King <brad.king@kitware.com>2013-11-18 16:30:50 (GMT)
commitfd6076d075d705c4731f71a544436ba82a1577bf (patch)
tree034d2bacc7745cd25ca11ccbc8712713f6b732e5 /Tests/CMakeLists.txt
parent68031abf15affedc72c13b8b7f1ff025f510bd20 (diff)
downloadCMake-fd6076d075d705c4731f71a544436ba82a1577bf.zip
CMake-fd6076d075d705c4731f71a544436ba82a1577bf.tar.gz
CMake-fd6076d075d705c4731f71a544436ba82a1577bf.tar.bz2
Tests: Pass CMAKE_MAKE_PROGRAM instead of --build-makeprogram
Pass the CMAKE_TEST_MAKEPROGRAM, if any, to each test at CMake time in the CMAKE_MAKE_PROGRAM cache entry. Pass the CMAKE_TEST_MAKEPROGRAM into the ExportImport, Fortran, and MacRuntimePath tests so that they may do the same for the nested project configurations. Now "ctest --build-and-test" can get the make program from the test build tree cache, so drop the explicit --build-makeprogram.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 43ae52a..6c3e478 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -80,7 +80,6 @@ if(BUILD_TESTING)
set(build_generator_args
--build-generator ${CMAKE_TEST_GENERATOR}
- --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
)
if(CMAKE_TEST_GENERATOR_TOOLSET)
list(APPEND build_generator_args
@@ -89,6 +88,9 @@ if(BUILD_TESTING)
endif()
set(build_options)
+ if(CMAKE_TEST_MAKEPROGRAM)
+ list(APPEND build_options -DCMAKE_MAKE_PROGRAM:FILEPATH=${CMAKE_TEST_MAKEPROGRAM})
+ endif()
add_subdirectory(CMakeLib)
add_subdirectory(CMakeOnly)
@@ -254,6 +256,7 @@ if(BUILD_TESTING)
ADD_TEST_MACRO(Assembler HelloAsm)
ADD_TEST_MACRO(SourceGroups SourceGroups)
ADD_TEST_MACRO(Preprocess Preprocess)
+ set(ExportImport_BUILD_OPTIONS -DCMAKE_TEST_MAKEPROGRAM:FILEPATH=${CMAKE_TEST_MAKEPROGRAM})
ADD_TEST_MACRO(ExportImport ExportImport)
ADD_TEST_MACRO(Unset Unset)
ADD_TEST_MACRO(PolicyScope PolicyScope)
@@ -465,7 +468,6 @@ if(BUILD_TESTING)
--build-two-config
--build-generator "Eclipse CDT4 - Unix Makefiles"
--build-generator-toolset "${CMAKE_TEST_GENERATOR_TOOLSET}"
- --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
--build-project Simple
--build-options ${build_options}
--test-command Simple)
@@ -481,7 +483,6 @@ if(BUILD_TESTING)
--build-two-config
--build-generator "CodeBlocks - Unix Makefiles"
--build-generator-toolset "${CMAKE_TEST_GENERATOR_TOOLSET}"
- --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
--build-project Simple
--build-options ${build_options}
--test-command Simple)
@@ -496,7 +497,6 @@ if(BUILD_TESTING)
--build-two-config
--build-generator "KDevelop3 - Unix Makefiles"
--build-generator-toolset "${CMAKE_TEST_GENERATOR_TOOLSET}"
- --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
--build-project Simple
--build-options ${build_options}
--test-command Simple)
@@ -1352,6 +1352,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
${build_generator_args}
--build-project MacRuntimePath
--build-options ${build_options}
+ -DCMAKE_TEST_MAKEPROGRAM:FILEPATH=${CMAKE_TEST_MAKEPROGRAM}
)
endif()
@@ -2504,6 +2505,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
--build-project testf
--build-two-config
--build-options ${build_options}
+ -DCMAKE_TEST_MAKEPROGRAM:FILEPATH=${CMAKE_TEST_MAKEPROGRAM}
--test-command testf)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Fortran")