summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-05-18 17:38:37 (GMT)
committerBrad King <brad.king@kitware.com>2023-05-18 17:42:42 (GMT)
commit80181da866329ce2f202a7129a49fb02f38e3902 (patch)
tree2d8df92272f2adbd42e00d0bf6b4b601201434c6 /Tests/CMakeLists.txt
parent21df34b25526225d04f9f5e6351c13e68425e195 (diff)
downloadCMake-80181da866329ce2f202a7129a49fb02f38e3902.zip
CMake-80181da866329ce2f202a7129a49fb02f38e3902.tar.gz
CMake-80181da866329ce2f202a7129a49fb02f38e3902.tar.bz2
Tests: Add option to control timeout of BootstrapTest
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index af4ac55..5ef77fd 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -3342,13 +3342,12 @@ if(BUILD_TESTING)
)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/BootstrapTest")
# This test will use all processors.
- set_tests_properties(BootstrapTest PROPERTIES RUN_SERIAL 1)
-
- # provide more time for the bootstrap test
- get_test_property(BootstrapTest TIMEOUT PREVIOUS_TIMEOUT)
- if("${PREVIOUS_TIMEOUT}" MATCHES NOTFOUND)
- set_tests_properties(BootstrapTest PROPERTIES TIMEOUT 5400)
+ set_property(TEST BootstrapTest PROPERTY RUN_SERIAL 1)
+ # This test may take a long time.
+ if(NOT DEFINED CMake_TEST_BOOTSTRAP_TIMEOUT)
+ set(CMake_TEST_BOOTSTRAP_TIMEOUT 5400)
endif()
+ set_property(TEST BootstrapTest PROPERTY TIMEOUT "${CMake_TEST_BOOTSTRAP_TIMEOUT}")
endif()
if(CMAKE_Fortran_COMPILER)