summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-08-07 18:53:57 (GMT)
committerBrad King <brad.king@kitware.com>2014-08-20 14:19:49 (GMT)
commitdf3b007d7f904f8de5877f3e05b629239af7220a (patch)
treebf0f6ea804beac70c0a41cf1647d90f16820f311 /Tests/CMakeLists.txt
parente872744990f48777a1f1cebc791911363515092d (diff)
downloadCMake-df3b007d7f904f8de5877f3e05b629239af7220a.zip
CMake-df3b007d7f904f8de5877f3e05b629239af7220a.tar.gz
CMake-df3b007d7f904f8de5877f3e05b629239af7220a.tar.bz2
VS: Add test for MASM support
It is now expected to work with VS >= 10 and MSVC >= 13.1.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index ca7fcdc..f237f21 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1679,6 +1679,11 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/MFC")
endif()
+ if(MSVC AND NOT MSVC_VERSION LESS 1310
+ AND NOT CMAKE_GENERATOR MATCHES "Visual Studio [6789]( |$)")
+ ADD_TEST_MACRO(VSMASM VSMASM)
+ endif()
+
if(${CMAKE_GENERATOR} MATCHES "Visual Studio")
if(NOT MSVC60)
ADD_TEST_MACRO(SBCS SBCS)