summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorEvan Wilde <etceterawilde@gmail.com>2022-09-12 22:15:24 (GMT)
committerEvan Wilde <etceterawilde@gmail.com>2022-09-19 18:37:48 (GMT)
commitf6ff19cc9d2ce51791f32b7e4fd0ad6d917a00cc (patch)
treecff84e33592c04b1a7f5e3c8625aaf2af378ffa6 /Tests/CMakeLists.txt
parent399343486f129f28b61683dbd95bec4ff16e60a0 (diff)
downloadCMake-f6ff19cc9d2ce51791f32b7e4fd0ad6d917a00cc.zip
CMake-f6ff19cc9d2ce51791f32b7e4fd0ad6d917a00cc.tar.gz
CMake-f6ff19cc9d2ce51791f32b7e4fd0ad6d917a00cc.tar.bz2
Tests: Add mixed Swift+CXX source test case
This test ensures we can configure and build mixed source binaries. The test configures, but fails to verify due to multiple targets emitting the `lib.c.o` and `lib.cpp.o` outputs. Both the clang build step and the swift link step report that they emit the `lib.c.o` and `lib.cpp.o` outputs. The `.o`'s are emitted by clang, not by swift.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index abe742e..3540aaa 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -394,6 +394,9 @@ if(BUILD_TESTING)
if(CMake_TEST_XCODE_SWIFT)
ADD_TEST_MACRO(SwiftMix SwiftMix)
endif()
+ if(CMAKE_Swift_COMPILER_VERSION VERSION_GREATER_EQUAL 5.1)
+ ADD_TEST_MACRO(SwiftMixLib Swifty)
+ endif()
endif()
if(CMAKE_Fortran_COMPILER)
ADD_TEST_MACRO(FortranOnly FortranOnly)